Jump to content
  • 0
mysticall

Inter VLAN Bridging

Въпрос

mysticall

Моля, влезте или се регистрирайте, за да видите този code.

Има два бриджа, единия е за интернет (bridge-nat), а другия за телефоните (bridge-eoip). На ether2 има Cisco 2960S, от което идва и влан 3, който е пуснат за телефоните.

ether2 е в bridge-nat за интернет, а vlan3 в bridge-eoip за телефоните, но когато добавя vlan3 в bridge-eoip, тестовия телефон за малко тръгва и после спира.

Не мога да разбера какво изпускам и къде греша.

Предполагам, че ако се пусне още едно ftp до cisco-то за влан3, горната схема ще заработи, но портовете микротика са пълни. Няма въжможност и за статично рутиране.

Сподели публикацията


Адрес на коментара
Сподели в други сайтове

14 отговори на този въпрос

Recommended Posts

  • 0
111111

Vlan-a го дигни на бриджа "bridge-nat" като по висшестоящ интерфейс.

 

Моля, влезте или се регистрирайте, за да видите този code.

не пречи да има на бриджа

Сподели публикацията


Адрес на коментара
Сподели в други сайтове
  • 0
mysticall

Няма промяна

Моля, влезте или се регистрирайте, за да видите този code.

 

Преди 1 час, JohnTRIVOLTA написа:

Може да пробваш без Hardware Offload на bridge-nat .

От къде се спира?

Сподели публикацията


Адрес на коментара
Сподели в други сайтове
  • 0
JohnTRIVOLTA
преди 15 минути, mysticall написа:

 

От къде се спира?

От самият бриджпорт.В твоят случай:

 /interface bridge port set hw=no numbers=1,9

Пусни RSTP на другият бридж също!

Сетни си пак вилан 3 на етер2 да не забравиш .

Редактирано от JohnTRIVOLTA

Сподели публикацията


Адрес на коментара
Сподели в други сайтове
  • 0
mysticall

Моля, влезте или се регистрирайте, за да видите този code.

Продължава да не работи.

RouterOS има собствено мнение за мрежовите решения 😀

Редактирано от mysticall

Сподели публикацията


Адрес на коментара
Сподели в други сайтове
  • 0
JohnTRIVOLTA

Сложи му arp=proxy-arp на bridge-eoip ... ти на друг борд през EoIP ли пробваш или се закаш за проба на етер5 на същият? Ако пробваш през тунела то да не забравиш да разрешиш и на двата борда протокола GRE на вход веригата !

Редактирано от JohnTRIVOLTA

Сподели публикацията


Адрес на коментара
Сподели в други сайтове
  • 0
mysticall

vlan3.png.516b91b0d66af1cc78d975bf2289a80f.png

Махнах Flood отметките и телефона започна да отговаря на пинг.

Докато преглеждах трафика във vlan3 с /tool sniffer ми направи впечатление, че телефона търси доста агресивно сървъра и пуска сериозен broadcast. Явно микротика го възприема като flood  и спира трафика. Ще оставя така нещата и да видим, ще продължи ли, да работи.

Пуснах  Hardware Offload.

преди 23 минути, JohnTRIVOLTA написа:

Сложи му arp=proxy-arp на bridge-eoip ... ти на друг борд през EoIP ли пробваш или се закаш за проба на етер5 на същият?

При статичното рутиране proxy-arp е задължително, но в моя случай няма да има ефект.

Главния сървър е зад друг борд. Този от който пробвам, се закача към главния с EoIP. Но има и телефони, които са закачени директно в ether на този от който пробвам. Системата е доста сложна и чуплива, но не е мое творение.

Сподели публикацията


Адрес на коментара
Сподели в други сайтове
  • 0
JohnTRIVOLTA

Тези отметки са да позволят такъв тип трафик, а така нечекнати го забраняваш за този порт . По-скоро proxy-arp ще трбва да е сетнат на бриджа, защото е от към клиентската част. Пробвай нещата на етер 5 - там ако тръгнат то ще излезат с вилан3 после ... дано съм разбрал схемата . Хардуерният офлоуд работи само върху един бридж с етер портове от един суич . 

Редактирано от JohnTRIVOLTA

Сподели публикацията


Адрес на коментара
Сподели в други сайтове
  • 0
mysticall
Преди 2 часа, kokaracha написа:

Моля, влезте или се регистрирайте, за да видите този code.

Моля, влезте или се регистрирайте, за да видите този code.

Направих mtu=1500 на интерфейсите, в които се разминаваше, но като маркирам горните отметки и пинга спира.

Не разбрах къде е проблема, но работи и ще го оставя така.

Сподели публикацията


Адрес на коментара
Сподели в други сайтове
  • 0
JohnTRIVOLTA

Тръгна ли телефона ? Хмм ...общо симтомите са все едно става някакъв луп в тази мрежа !

Сподели публикацията


Адрес на коментара
Сподели в други сайтове
  • 0
mysticall

Възможно е да има loop. Докато преглеждах трафика cisco изпращаше пакети от тип=LOOP,  но ме съмнява проблема да е от конфигурацията на cisco -

Моля, влезте или се регистрирайте, за да видите този attachment.

Не съм правил, кой знае какви настройки.

С толкова сложна система, loop-а може даже да не е в този микротик.

Редактирано от mysticall

Сподели публикацията


Адрес на коментара
Сподели в други сайтове
  • 0
111111

Mikrotik-а има детектор за лупове активирай го.

Сподели публикацията


Адрес на коментара
Сподели в други сайтове
  • 0
mysticall

Оказа се, че в главния микротик има пуснато proxy-arp и с eoip тунелите, които са свързани към него влиза паразитен трафик. Направих малки промени в настройките на работните места, където има телефони и са свързани с eoip тунел. Паразитния трафик изчезна (надявам се) и телефонията през vlan3 просто заработи, както и се очаква да бъде.

 

Сподели публикацията


Адрес на коментара
Сподели в други сайтове

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Гост
Отговори на въпроса...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Потребители разглеждащи страницата   0 потребители

    No registered users viewing this page.

×
×
  • Създай нов...

Important Information

By using this site, you agree to our Terms of Use.