Jump to content
  • 0

Inter VLAN Bridging


mysticall
 Share

Question

[mirotik@office] > /interface bridge print 
Flags: X - disabled, R - running 
 0 R name="bridge-eoip" mtu=auto actual-mtu=1458 l2mtu=1598 arp=enabled arp-timeout=auto 
     mac-address=64:D1:54:B5:18:F3 protocol-mode=none fast-forward=no igmp-snooping=no auto-mac=yes 
     ageing-time=5m vlan-filtering=no dhcp-snooping=no 

 1 R name="bridge-nat" mtu=auto actual-mtu=1500 l2mtu=1598 arp=enabled arp-timeout=auto 
     mac-address=64:D1:54:B5:18:F5 protocol-mode=none fast-forward=no igmp-snooping=no auto-mac=yes 
     ageing-time=5m vlan-filtering=no dhcp-snooping=no 

[mirotik@office] > /interface vlan print   
Flags: X - disabled, R - running 
 #   NAME                                  MTU ARP             VLAN-ID INTERFACE                              
 0 R ;;; Serviz Phones
     vlan3                                1500 enabled               3 ether2

[mirotik@office] > /interface bridge port print  
Flags: X - disabled, I - inactive, D - dynamic, H - hw-offload 
 #     INTERFACE               BRIDGE               HW  PVID PRIORITY  PATH-COST INTERNAL-PATH-COST    HORIZON
 0     sfp1                    bridge-nat           yes    1     0x80         10                 10       none
 1   H ether3                  bridge-nat           yes    1     0x80         10                 10       none
 2     wlan1                   bridge-nat                  1     0x80         10                 10       none
 3 I   wlan2                   bridge-nat                  1     0x80         10                 10       none
 4 I   ether4                  bridge-eoip          yes    1     0x80         10                 10       none
 5     ether5                  bridge-eoip          yes    1     0x80         10                 10       none
 6     eoip-tunnel1            bridge-eoip                 1     0x80         10                 10       none
 9   H ether2                  bridge-nat           yes    1     0x80         10                 10       none

Има два бриджа, единия е за интернет (bridge-nat), а другия за телефоните (bridge-eoip). На ether2 има Cisco 2960S, от което идва и влан 3, който е пуснат за телефоните.

ether2 е в bridge-nat за интернет, а vlan3 в bridge-eoip за телефоните, но когато добавя vlan3 в bridge-eoip, тестовия телефон за малко тръгва и после спира.

Не мога да разбера какво изпускам и къде греша.

Предполагам, че ако се пусне още едно ftp до cisco-то за влан3, горната схема ще заработи, но портовете микротика са пълни. Няма въжможност и за статично рутиране.

Link to comment
Share on other sites

14 answers to this question

Recommended Posts

  • 0
  • Administrator

Vlan-a го дигни на бриджа "bridge-nat" като по висшестоящ интерфейс.

 

protocol-mode=rstp 
fast-forward=yes

не пречи да има на бриджа

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0

Няма промяна

[mirotik@office] > /interface vlan print
Flags: X - disabled, R - running 
 #   NAME                                  MTU ARP             VLAN-ID INTERFACE                              
 0 R ;;; Serviz Phones
     vlan3                                1500 enabled               3 bridge-nat                             
[mirotik@office] > /interface bridge print 
Flags: X - disabled, R - running 
 0 R name="bridge-eoip" mtu=auto actual-mtu=1458 l2mtu=1594 arp=enabled arp-timeout=auto 
     mac-address=64:D1:54:B5:18:F3 protocol-mode=none fast-forward=no igmp-snooping=no auto-mac=yes 
     ageing-time=5m vlan-filtering=no dhcp-snooping=no 

 1 R name="bridge-nat" mtu=auto actual-mtu=1500 l2mtu=1598 arp=enabled arp-timeout=auto 
     mac-address=64:D1:54:B5:18:F5 protocol-mode=rstp fast-forward=yes igmp-snooping=no auto-mac=yes 
     ageing-time=5m priority=0x8000 max-message-age=20s forward-delay=15s transmit-hold-count=6 
     vlan-filtering=no dhcp-snooping=no 

 

Преди 1 час, JohnTRIVOLTA написа:

Може да пробваш без Hardware Offload на bridge-nat .

От къде се спира?

Link to comment
Share on other sites

  • 0
преди 15 минути, mysticall написа:

 

От къде се спира?

От самият бриджпорт.В твоят случай:

 /interface bridge port set hw=no numbers=1,9

Пусни RSTP на другият бридж също!

Сетни си пак вилан 3 на етер2 да не забравиш .

Edited by JohnTRIVOLTA
Link to comment
Share on other sites

  • 0
[mirotik@office] > /interface bridge print                     
Flags: X - disabled, R - running 
 0 R name="bridge-eoip" mtu=auto actual-mtu=1458 l2mtu=1594 arp=enabled arp-timeout=auto mac-address=64:D1:54:B5:18:F3 
     protocol-mode=rstp fast-forward=yes igmp-snooping=no auto-mac=yes ageing-time=5m priority=0x8000 max-message-age=20s 
     forward-delay=15s transmit-hold-count=6 vlan-filtering=no dhcp-snooping=no 

 1 R name="bridge-nat" mtu=auto actual-mtu=1500 l2mtu=1598 arp=enabled arp-timeout=auto mac-address=64:D1:54:B5:18:F5 
     protocol-mode=rstp fast-forward=yes igmp-snooping=no auto-mac=yes ageing-time=5m priority=0x8000 max-message-age=20s 
     forward-delay=15s transmit-hold-count=6 vlan-filtering=no dhcp-snooping=no 
   
[mirotik@office] > /interface vlan print                       
Flags: X - disabled, R - running 
 #   NAME                                          MTU ARP             VLAN-ID INTERFACE                                      
 0 R ;;; Serviz Phones
     vlan3                                        1500 enabled               3 ether2
   
[mirotik@office] > /interface bridge port print                
Flags: X - disabled, I - inactive, D - dynamic, H - hw-offload 
 #     INTERFACE                       BRIDGE                       HW  PVID PRIORITY  PATH-COST INTERNAL-PATH-COST    HORIZON
 0     sfp1                            bridge-nat                   yes    1     0x80         10                 10       none
 1     ether3                          bridge-nat                   no     1     0x80         10                 10       none
 2     wlan1                           bridge-nat                          1     0x80         10                 10       none
 3 I   wlan2                           bridge-nat                          1     0x80         10                 10       none
 4 I H ether4                          bridge-eoip                  yes    1     0x80         10                 10       none
 5   H ether5                          bridge-eoip                  yes    1     0x80         10                 10       none
 6     eoip-tunnel1                    bridge-eoip                         1     0x80         10                 10       none
 9     ether2                          bridge-nat                   no     1     0x80         10                 10       none
10     vlan3                           bridge-eoip                         1     0x80         10                 10       none

Продължава да не работи.

RouterOS има собствено мнение за мрежовите решения ?

Edited by mysticall
Link to comment
Share on other sites

  • 0

Сложи му arp=proxy-arp на bridge-eoip ... ти на друг борд през EoIP ли пробваш или се закаш за проба на етер5 на същият? Ако пробваш през тунела то да не забравиш да разрешиш и на двата борда протокола GRE на вход веригата !

Edited by JohnTRIVOLTA
Link to comment
Share on other sites

  • 0

vlan3.png.516b91b0d66af1cc78d975bf2289a80f.png

Махнах Flood отметките и телефона започна да отговаря на пинг.

Докато преглеждах трафика във vlan3 с /tool sniffer ми направи впечатление, че телефона търси доста агресивно сървъра и пуска сериозен broadcast. Явно микротика го възприема като flood  и спира трафика. Ще оставя така нещата и да видим, ще продължи ли, да работи.

Пуснах  Hardware Offload.

преди 23 минути, JohnTRIVOLTA написа:

Сложи му arp=proxy-arp на bridge-eoip ... ти на друг борд през EoIP ли пробваш или се закаш за проба на етер5 на същият?

При статичното рутиране proxy-arp е задължително, но в моя случай няма да има ефект.

Главния сървър е зад друг борд. Този от който пробвам, се закача към главния с EoIP. Но има и телефони, които са закачени директно в ether на този от който пробвам. Системата е доста сложна и чуплива, но не е мое творение.

Link to comment
Share on other sites

  • 0

Тези отметки са да позволят такъв тип трафик, а така нечекнати го забраняваш за този порт . По-скоро proxy-arp ще трбва да е сетнат на бриджа, защото е от към клиентската част. Пробвай нещата на етер 5 - там ако тръгнат то ще излезат с вилан3 после ... дано съм разбрал схемата . Хардуерният офлоуд работи само върху един бридж с етер портове от един суич . 

Edited by JohnTRIVOLTA
Link to comment
Share on other sites

  • 0
Eoip mtu=1500

Use since

OpenBSD 3.x

FreeBSD 4.x

Centos 5.x Debian 3.x Ubuntu 7.x

Аз съм фен на OpenWRT.

 

Горчивината от лошото качество остава дълго след като е преминало удоволствието от ниската цена.

_____________________________

___|____|____|____|____|____|__

_|____|____|____|____|____|____

___|____|_ Удряй _|____|____|__

_|____|___ главата ___|____|____

___|____|_ си тук!! |____|____|__

_|____|____|____|____|____|____

___|____|____|____|____|____|__

Link to comment
Share on other sites

  • 0
Преди 2 часа, kokaracha написа:

Eoip mtu=1500
[mirotik@office] > interface bridge print 
Flags: X - disabled, R - running 
 0 R name="bridge-eoip" mtu=1500 actual-mtu=1500 l2mtu=1594 arp=enabled arp-timeout=auto 
     mac-address=64:D1:54:B5:18:F3 protocol-mode=rstp fast-forward=yes igmp-snooping=no 
     auto-mac=yes ageing-time=5m priority=0x8000 max-message-age=20s forward-delay=15s 
     transmit-hold-count=6 vlan-filtering=no dhcp-snooping=no 

 1 R name="bridge-nat" mtu=auto actual-mtu=1500 l2mtu=1598 arp=enabled arp-timeout=auto 
     mac-address=64:D1:54:B5:18:F5 protocol-mode=rstp fast-forward=yes igmp-snooping=no 
     auto-mac=yes ageing-time=5m priority=0x8000 max-message-age=20s forward-delay=15s 
     transmit-hold-count=6 vlan-filtering=no dhcp-snooping=no
       
[mirotik@office] > interface vlan  print     
Flags: X - disabled, R - running 
 #   NAME                             MTU ARP             VLAN-ID INTERFACE                          
 0 R ;;; Serviz Phones
     vlan3                           1500 enabled               3 ether2

Направих mtu=1500 на интерфейсите, в които се разминаваше, но като маркирам горните отметки и пинга спира.

Не разбрах къде е проблема, но работи и ще го оставя така.

Link to comment
Share on other sites

  • 0

Тръгна ли телефона ? Хмм ...общо симтомите са все едно става някакъв луп в тази мрежа !

Link to comment
Share on other sites

  • 0

Възможно е да има loop. Докато преглеждах трафика cisco изпращаше пакети от тип=LOOP,  но ме съмнява проблема да е от конфигурацията на cisco -2960S.txt

Не съм правил, кой знае какви настройки.

С толкова сложна система, loop-а може даже да не е в този микротик.

Edited by mysticall
Link to comment
Share on other sites

  • 0
  • Administrator

Mikrotik-а има детектор за лупове активирай го.

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0

Оказа се, че в главния микротик има пуснато proxy-arp и с eoip тунелите, които са свързани към него влиза паразитен трафик. Направих малки промени в настройките на работните места, където има телефони и са свързани с eoip тунел. Паразитния трафик изчезна (надявам се) и телефонията през vlan3 просто заработи, както и се очаква да бъде.

 

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.