Jump to content
Dimitrov

Usermanager Paypal time out

Recommended Posts

Dimitrov

Здравейте и за много години!
Ползвам версия 6.23 на ROS, правя платен хотспот (с paypal) с usermanager и signup функцията. Самия хотспот работи, ако създам потребител с мениджъра и му задам профил. За да симулирам реално плащане използвам sandbox paypal. Използвах http://forum.mikrotik.com/viewtopic.php?f=10&t=81153за упътване, друго не можах да намеря. Настроил съм SNTP, static dns (както пише във форума)
За по-лесно ще обясня какво мога да правя и какво не.

При свързване с хотспота ми излиза класическата страница за име и парола. Отивам на signup страницата, пиша си данните и избирам профил, препратен съм към sandbox.paypal.com (заради променения ред в signup_pay_form.html). Самия sandbox зарежда, извършвам плащане чрез тестов акаунт, всичко е успешно. При опит да вляза с профила обаче ми изписва, че няма такъв потребител. В usermanager-a плащането на въпросния неактивиран потребител (не му е назначен профил) виси за известно време като waiting, накрая става time out. 

 

Имам съмнение за сертификата, който генерирах през ubuntu терминал (http://wiki.mikrotik.com/wiki/Manual:Create_Certificates). Метода с генериране през самия рутер не ми проработи (дава грешка на реда sign template=ca-template ca-crl-host=x.x.x.x name=myCa). С този от ubuntu ми дава флагове KT вместо KR, както пише, че трябва. https://routerip ми дава грешка за сигурността, предполагам, че така се тества дали работи. 
Въпросът ми е, в крайна сметка заради сертификата ли се спира потвърждението на плащането, или има нещо друго, което да погледна.
Обобщавам:  потребителя може сам да си направи акаунт, плащането се осъществява (другата страна получава парите), акаунта се създава като неактивен, но така и не се активира, крайния резултат е time out. 
Ако не е достатъчна информацията, моля да кажете.
 

Share this post


Link to post
Share on other sites
111111

IP или DNS име опитваш за сертификата?

А и на безплатните сертификати са им орезани крилцата доста.

Share this post


Link to post
Share on other sites
Dimitrov

Ползвам си IP-то на рутера. Ще пробвам с някой истински SSL (ама trial).

Share this post


Link to post
Share on other sites
111111

Лог-а казва ли нещо?

Share this post


Link to post
Share on other sites
Dimitrov

Нищо. Ще се помъча още... новичък съм в сферата и ми идва в повече информацията. Ако искам да ползвам истински сертификат, задължително ли ми трябва домейн? Тоест трябва по някакъв начин да обърна локалното ИП в уеб адрес?

-----

Добре, поразбрах за сертификатите, но май не е в тях проблема. При настройките на subscriber в usermanager-a има Public Host. В wiki пише:
"If users access User Manager page through a local IP address, public host attribute must be specified. It must contain a public address of User Manager router which is acceptable as Relay URL for Authorize.Net gateway (See: Authorize.Net Merchant account configuration). Domain name or IP address can be used. Only the address must be specified, not URL (for example, userman.mt.lv, not and not

Please login or register to see this content.

 

Досега бях сложил локалното ИП на рутера (не знам защо), което не отговаря на условието да се достъпва отвън... сега пробвах с домейн, който регистрирах на публичното ми ИП.
С port forwarding на първия ми рутер (от доставчика) съм пренасочил порт 80 към ИП-то на рутера. Така от външна мрежа може да се влезе до рутера. Добавил съм NAT правило за същото в winbox. Така мога да достъпя логин страницата през домейна, когато се свързвам през хотспот мрежата. Домейна не мога да го достъпя от LAN и от мрежата на първия рутер (на доставчика).

 

Та сложих домейна на мястото на Public host, при което когато извърша плащане изписва, че е успешно и настават катаклизми. Рутера забива. Не може да се влезе нито в него, нито в хотспота. Първия път, когато заби (и му дръпнах кабела), рутера си смени ИП-то... Следващите пъти пак забиваше, но поне си остана на същия адрес. 

Явно е тук проблемът (и sandbox да не му трябва SSL), но не знам какво да направя. Моля за още някой съвет.
---

Свързах си локалното ИП с публичното и мога да го достъпя отвън, но пак забива... ако махна ИП-то от полето Public Host няма забиване, но пак няма активиране на профила...


Сетих се да видя ресурс монитора... оказва се, че когато пусна заявка за плащане рамта отива на 1-2kB, а процесора зацикля на 100%. След което рутера забива и му трябва вадене на кабел.

Edited by Dimitrov

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.