Jump to content

Търсене на решение за проблеми с Wi-Fi


Recommended Posts

JohnTRIVOLTA

От инфото което споделяш най-вероятно "...или съм омазал нещо по конфигурациите?" .

Като начало може да рисетнеш борда без да зарежда деф. конфиг. Добавяш си бридж и си вкарваш в него етернет потовете или само етер1. Казваш на cAP дискавъри интерфейса да е него бридж и по-долу за локал форуадинг избираш за бридж също него, предполага се че ще искаш да се виждат устройствата в LAN, които са свързани безжично в следствие.

Недей слага адреси и прочие по АП-тата, а си ги достъпвай устройствата по мак адрес, поне в началото, ако е нужно . Нали за това е мениджъра, центализирано да ги управляваш, а не всяко да го достъпваш по отделно.

Edited by JohnTRIVOLTA
Link to post
Share on other sites
linuxxp
Posted (edited)

Благодаря ти за отговора. hex S-а едва ли е омазан, защото той си работи без никакви проблеми. Преди да го ъпдейтна беше с ъптайм над 90 дни (закачен е на UPS). Неработещото АР се държи изключително странно със смяната си на МАС адреса и изхвърлянето от Winbox. Проблема се оправя след поредица от ресетване на конфига, докато започне да работи нормално. Ресетвам през конзолата, през Winbox и със задържането на бутона.

На hex S имам добавен бридж. На АР-то съм пуснал опцията "Bridge All LAN Ports". Дискавъри интърфейса го слагам eth1.

Edited by linuxxp
Link to post
Share on other sites
JohnTRIVOLTA
преди 6 минути, linuxxp написа:

Благодаря ти за отговора. hex S-а едва ли е омазан, защото той си работи без никакви проблеми. Преди да го ъпдейтна беше с ъптайм над 90 дни (закачен е на UPS). Неработещото АР се държи изключително странно със смяната си на МАС адреса и изхвърлянето от Winbox. Проблема се оправя след поредица от ресетване на конфига, докато започне да работи нормално. Ресетвам през конзолата, през Winbox и със задържането на бутона.

На hex S имам добавен бридж. На АР-то съм пуснал опцията "Bridge All LAN Ports". Дискавъри интърфейса го слагам eth1.

Говоря само за проблемното АП . Няма значение как го рисетваш АПто , важното да е с no-defaults=yes ! Както казах по-горе , че слагаш интерфейса Bridge за дискавъри интерфейс. Като оставим настрана , че трябва да си избереш безжичните интерфейси, които ще се управляват от мениджъра нищо друго не е нужо ... може hostname да смениш на АПтата /Identity/ също .

Link to post
Share on other sites
linuxxp
Posted (edited)

Конфиг на пробленото АР:

# jan/03/2021 15:03:49 by RouterOS 6.48
# software id = I9JW-J75J
#
# model = RBcAPGi-5acD2nD
# serial number = CBE30D99AB21
/interface bridge
add name=bridge1
/interface wireless
# managed by CAPsMAN
# channel: 2412/20-Ce/gn(18dBm), SSID: Toothless_2.4, CAPsMAN forwarding
set [ find default-name=wlan1 ] ssid=MikroTik
# managed by CAPsMAN
# channel: 5180/20-Ceee/ac/P(20dBm), SSID: Toothless, CAPsMAN forwarding
set [ find default-name=wlan2 ] ssid=MikroTik
/interface list
add name=WAN
add name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot profile
set [ find default=yes ] html-directory=hotspot
/interface bridge filter
add action=drop chain=input dst-port=68 in-interface=ether1 ip-protocol=udp \
    mac-protocol=ip
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=wlan2
add bridge=bridge1 interface=wlan1
/ip neighbor discovery-settings
set discover-interface-list=!dynamic
/interface list member
add interface=ether1 list=WAN
add interface=ether2 list=LAN
add interface=wlan2 list=LAN
add interface=wlan1 list=LAN
/interface wireless cap
# 
set bridge=bridge1 discovery-interfaces=ether1 enabled=yes interfaces=\
    wlan2,wlan1
/ip dhcp-client
add disabled=no interface=bridge1
/system clock
set time-zone-name=Europe/Sofia
/system identity
set name=AP1

 

 

Конфиг на работещото АР:

# jan/03/2021 15:10:23 by RouterOS 6.48
# software id = DKJA-SJWG
#
# model = RBcAPGi-5acD2nD
# serial number = BED00DE9B93C
/interface bridge
add name=bridge1
/interface wireless
# managed by CAPsMAN
# channel: 2432/20-Ce/gn(18dBm), SSID: Toothless_2.4, CAPsMAN forward
set [ find default-name=wlan1 ] ssid=MikroTik
# managed by CAPsMAN
# channel: 5560/20-eeCe/ac/DP(24dBm), SSID: Toothless, CAPsMAN forwar
set [ find default-name=wlan2 ] ssid=MikroTik
/interface list
add name=WAN
add name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot profile
set [ find default=yes ] html-directory=hotspot
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=wlan2
add bridge=bridge1 interface=wlan1
/ip neighbor discovery-settings
set discover-interface-list=!dynamic
/interface list member
add interface=ether1 list=WAN
add interface=ether2 list=LAN
add interface=wlan2 list=LAN
add interface=wlan1 list=LAN
/interface wireless cap
# 
set bridge=bridge1 discovery-interfaces=ether1 enabled=yes interfaces
    wlan2,wlan1
/ip dhcp-client
add disabled=no interface=bridge1
/system clock
set time-zone-name=Europe/Sofia
/system identity
set name=AP2

 

Единствената разлика е "add action=drop chain=input dst-port=68 in-interface=ether1 ip-protocol=udp \
    mac-protocol=ip" в конфига на неработещия, което не знам от къде е сетнато.

 

За да спре постоянното изхвъряне от Winbox трябва да затворя всички отворени под прозорци. В момента в който станат на 3 и започва да ме изхвърля.

Edited by linuxxp
Link to post
Share on other sites
JohnTRIVOLTA

Сякаш не ме разбираш какво по-горе ти писах ?

Edited by JohnTRIVOLTA
Link to post
Share on other sites
linuxxp

Разбрах те, че трябва да си ресетна АР-тата без начална конфигурация, да си сменя идентитио и да не задавм статични адреси и всичко трябва да тръгне.

Link to post
Share on other sites
JohnTRIVOLTA
преди 4 минути, linuxxp написа:

Разбрах те, че трябва да си ресетна АР-тата без начална конфигурация, да си сменя идентитио и да не задавм статични адреси и всичко трябва да тръгне.

Точно така ! Дори те съветвам статично да си зададеш радиата в мениджъра от колкото динамично, все пак са само четири .

Link to post
Share on other sites
master

Мак адреса се сменя ако на бриджа не си забил admin mac. Това ми се е случвало с бриджа при вкл. / изкл. на клиенти.

До момента никога не сме имали проблем при клиент с два тп линка в режим ап с едно ссид и друг рутер с изключение на факта, че понякога сами си пускат дхцп или забиване от ерп то. Там където се изисква слагаме микротик рутери в конфигурация бридж етернет и вифи. Отделен микротик се ползва само за рутер. Никога не е имало проблеми.

Analog Audio™

Link to post
Share on other sites
linuxxp

@JohnTRIVOLTA

 

Благодаря! Махнах статичните адреси и всичко тръгна. Работи вече няколко дни без проблеми. Задал съм си радиата ръчно.

 

master

С този модел рутер тплинк по принцип нямам проблем. Инсталирал съм няколко такива и в двата режима (рутер и АР). Само в нас има проблем. Все пак реших да мина на цялостно решение на микротик. Последно устройствата вкъщи станаха над 30, около 20 са свързани безжично.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.