Jump to content
  • 0
johnnie

Vivacom IPTV

Question

johnnie

Здравейте,

От около месец се опитвам да подкарам Vivacom IPTV на няколко Mikrotik рутера. Очаквания резултат е да имам IPTV + NET на първия рутер, които да мога да изпратя до втория ( и третия ), на който има закачено едно STB и няколко LAN клиента.

Идеята зад тази сложна конфигурация е , че всички кабели са положени в стените ( по един кабел на стая ) и се групират в разпределителна кутия над входната врата. В момента там има Tplink switch от Vivacom, към който са закачени STB-тата и един HAP ac2. Телевизия има, Wi-Fi също има, но не навсякъде най-вероятно строителите не са пестили от арматура и бетон. Също така няколко устройства, които изискват кабелна връзка ( NAS ) стоят и събират прах.

Всички устройства трябва да са в една мрежа, което усложнява нещата ... иначе всичко на Tplink-а и готово.

 

Опитах с IGMP Proxy, но телевизия не тръгва дори на първия рутер: Upstream ether1(WAN) downstream bridge.

Опитах и с VLAN-и , пак без успех:

/interface bridge
add fast-forward=no igmp-snooping=yes name=IPTV
/interface vlan
add interface=ether1 name=vlan6-ether1 vlan-id=6
/interface bridge port
add bridge=IPTV interface=vlan6-ether1
add bridge=IPTV interface=etherX

Някой може ли да ме упъти към възможен работещ вариант защото вече се изчерпах от към идеи а и знанията ми не са завидни :) .

 

image.thumb.png.18a921196ad32efd03243ba190d7b64d.png 

 

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0
111111

VLAN през интернет няма да мине посмъртно.

Правиш си SSTP/L2TP + EOIP тунели и през тях става работата.

IGMP няма защо да се мъчиш освен мултикаста минава и друг трафик та вместо да имаш главоболия спести си ги.

R1

port 1+STB портовете в бридж с тунела до другите рутери на бриджа нат за останалите портове които искаш да има интернет

R2-3-4
порт STB в бридж с тунела от R1  

Share this post


Link to post
Share on other sites
  • 0
johnnie

Благодаря за бързото предложение ! 

 

Току що разбрах, че не съм се изразил много правилно рутер2 и рутер3, ще бъдат закачени с кабел за първия рутер и на тях ще бъдат закачени крайните LAN клиенти + STB-тата. За момента разполагам само с рутер2 - HAP Lite, когато съм сигурен, че тази конфигурация работи ще закупя друг hardware.

Share this post


Link to post
Share on other sites
  • 0
111111

Ползвай EoIP тунел само, с бриджовете.

Share this post


Link to post
Share on other sites
  • 0
johnnie

Прочетох документацията изглежда лесно и просто. По-късно или утре през деня ще опитам.

Само не ми е много ясно какво да правя с телевизията как да я вкарам нея в бриджа на първия рутер ?

Share this post


Link to post
Share on other sites
  • 0
111111

Бодеш кабела на порт едно и на порт 2 ако има STB ги вкарваш в бридж с ЕОИП тунелите
на бриджа си пускаш адреса, натваш и си имаш нет

Share this post


Link to post
Share on other sites
  • 0
_mi_

Мислих да пусна нова тема, но се надявам колегата да няма напротив да попитам тук!
В момента мрежата ми е:
RB951 -> ether1(WAN vivacom dhcp client) + ether2(към обикновен суич за тв-tata) in Bridge 1
             -> ether3,4,5,wlan,eoip са на Bridge2(DHCP server)
Та, сега си мисля дали мога да реализирам това:
ether1(wan)
Ether2,3,4,5,wlan,eoip на bridge1 и като свържа STB-то към примерно ether3 да тръгне тв-то. Аз знам че няма да стане е така. Каккво трябва да се направи, ако изобщо е възможно?

Share this post


Link to post
Share on other sites
  • 0
111111

за да стане това трябва да направиш недореализираната логика на смартком

мониторинг на порта 
ако мак адреса е на STB, порта да мине във vlan към WAN.

Цлялото това нещо става и с DHCP, но е доста писане.

Share this post


Link to post
Share on other sites
  • 0
johnnie

@111111: Благодаря много ! 

Успях да настроя две от устройствата има и телевизия има и нет :).

Поздрави

Share this post


Link to post
Share on other sites
  • 0
111111

Това решение съм го реализирал още от как на ТП-Линк 740 му портнаха първия DDWRT и ентуситите го мъчеха с горното упражнение.

Работи и с А1.

Share this post


Link to post
Share on other sites
  • 0
_mi_

А аз създадох тунел eoip. 

Site A - port1(wan vivacom ), port2(to switch за телевизорите TV).  bridge1(port1, port2,  eoipTvtunel), 

Site B - port1(wan pppoe),  bridge1(port5(STB) ,  eoipTv) 

Но не тръгна... Mtu то от едната страна е около 1280, а другата 1460...

Някакви идеи? 

 

Share this post


Link to post
Share on other sites
  • 0
JohnTRIVOLTA

Между site A и site B създай L2TP връзка на което ще сетнеш от двете страни MRRU=1600 . Задай после EoIP тунела да ползва нея  връзка /адресите на l2 тунела/ и за транспорт ! Така няма да имаш пресегментиране на пакетите , а реконструиране им на по-ниско ниво, което е по-добрият вариант особенно, когато MTU пада на много ниски стойности!

Share this post


Link to post
Share on other sites
  • 0
_mi_

Добре, направих l2 и прекарах eoip по него, сега Mtu  е 1554 в двете страни!
Но нещо пан не тръгва! 
Виждам, че има някакъв трафик в тунелите, но не е стабилен! 
 

Share this post


Link to post
Share on other sites
  • 0
JohnTRIVOLTA
Преди 1 час, _mi_ написа:

Добре, направих l2 и прекарах eoip по него, сега Mtu  е 1554 в двете страни!
Но нещо пан не тръгва! 
Виждам, че има някакъв трафик в тунелите, но не е стабилен! 
 

GRE си разрешил на вход нали - при всички рутери?

Edited by JohnTRIVOLTA

Share this post


Link to post
Share on other sites
  • 0
_mi_

Не бях! Сега го разрешин (chain -> input, protocol -> gre, action -> accept) от двете страни!

Все още не тръгва! 

Share this post


Link to post
Share on other sites
  • 0
JohnTRIVOLTA
преди 5 минути, _mi_ написа:

Не бях! Сега го разрешин (chain -> input, protocol -> gre, action -> accept) от двете страни!

Все още не тръгва! 

Виж си правилата в стената ! Може за проба да изключиш всичко що е правило за chain=forward пример .

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.